로그인
Sign in
Extra Form
FAQ내용 [FAQ67] 교회에서 예배를 위해 넘버원 리눅스와 OpenLP를 사용하고자 합니다. 넘버원 리눅스 저장소로부터 이 패키지를 설치한 후 openlp를 실행하면 오류가 발생합니다. 어떻게 하면 Openlp를 실행할 수 있을까요?

$ openlp
Traceback (most recent call last):
File "/usr/bin/openlp", line 27, in <module>
from openlp.core.common import is_win, is_macosx
File "/usr/lib/python3.6/site-packages/openlp/__init__.py", line 26, in <module>
from openlp import core, plugins
File "/usr/lib/python3.6/site-packages/openlp/core/__init__.py", line 41, in <module>
from openlp.core.lib import ScreenList
File "/usr/lib/python3.6/site-packages/openlp/core/lib/__init__.py", line 331, in <module>
from .renderer import Renderer
File "/usr/lib/python3.6/site-packages/openlp/core/lib/renderer.py", line 31, in <module>
from openlp.core.ui import MainDisplay
File "/usr/lib/python3.6/site-packages/openlp/core/ui/__init__.py", line 120, in <module>
from .projector.manager import ProjectorManager
File "/usr/lib/python3.6/site-packages/openlp/core/ui/projector/manager.py", line 42, in <module>
from openlp.core.lib.projector.db import ProjectorDB
File "/usr/lib/python3.6/site-packages/openlp/core/lib/projector/db.py", line 45, in <module>
from openlp.core.lib.db import Manager, init_db, init_url
File "/usr/lib/python3.6/site-packages/openlp/core/lib/db.py", line 34, in <module>
from alembic.migration import MigrationContext
ModuleNotFoundError: No module named 'alembic'

Openlp 실행 환경
메뉴분류 오피스

넘버원 리눅스 저장소에 있는 openlp 패키지를 설치한 후 실행할 경우 파이썬 모듈 의존성 문제로 실행되지 않습니다. Openlp rpm 패키지에 패키지 의존성을 충족할 수 있도록 openlp에 필요한 파이썬 모듈을 제공하였습니다만, alembic 모듈이 누락되어 있는 상태입니다. alembic 모듈이 설치되어 있지 않기 때문에 이 모듈을 추가로 설치해 주어야 합니다. 이 모듈(이 모듈뿐만 아니라 의존성 파이썬 모듈이 없을 경우)을 설치하기 위해서는 pip 모듈 설치 도구를 설치해야 합니다.


콘솔창에서 apt-get install python-pip 명령으로 PIP를 설치하거나 시냅틱에서 python-pip를 검색하여 설치합니다. pip를 설치하였다면 콘솔상에서 'pip install 설치할모듈명' 명령으로 필요한 파이썬 모듈을 설치합니다. 따라서 alembic 모듈은 pip install alembic 명령으로 설치합니다. 


[root@localhost dumca]# pip install alembic
WARNING: WARNING: Running pip install with root privileges is generally not a good idea. Try `pip install --user` instead.                                                                                                               
Collecting alembic
  Downloading https://files.pythonhosted.org/packages/9a/0f/a5e8997d58882da8ecd288360dddf133a83145de6480216774923b393422/alembic-1.1.0.tar.gz (1.0MB)
     |████████████████████████████████| 1.0MB 237kB/s
Requirement already satisfied: SQLAlchemy>=1.1.0 in /union/usr/lib64/python3.6/site-packages (from alembic) (1.2.6)
Requirement already satisfied: Mako in /union/usr/lib/python3.6/site-packages (from alembic) (1.0.9)
Collecting python-editor>=0.3 (from alembic)
  Downloading https://files.pythonhosted.org/packages/c6/d3/201fc3abe391bbae6606e6f1d598c15d367033332bd54352b12f35513717/python_editor-1.0.4-py3-none-any.whl
Collecting python-dateutil (from alembic)
  Downloading https://files.pythonhosted.org/packages/41/17/c62faccbfbd163c7f57f3844689e3a78bae1f403648a6afb1d0866d87fbb/python_dateutil-2.8.0-py2.py3-none-any.whl (226kB)
     |████████████████████████████████| 235kB 352kB/s
Requirement already satisfied: MarkupSafe>=0.9.2 in /union/usr/lib64/python3.6/site-packages (from Mako->alembic) (1.0)
Requirement already satisfied: six>=1.5 in /union/usr/lib/python3.6/site-packages (from python-dateutil->alembic) (1.11.0)
Installing collected packages: python-editor, python-dateutil, alembic
  Running setup.py install for alembic ... done
Successfully installed alembic-1.1.0 python-dateutil-2.8.0 python-editor-1.0.4

pip 모듈설치도구로 alembic 모듈을 설치하게 되면 넘버원 리눅스의 파이썬이 원하는 경로가 아닌 다른 경로(/usr/local/lib/python3.6/site-packages)에 설치되기 때문에 openlp를 실행할 경우 오류가 발생하므로 설치된 alembic 경로를 /usr/lib/python3.6/site-packages 경로로 이동시켜 주어야 하는데 다음과 같이 실행합니다.


# mv /usr/local/lib/python3.6/site-packages/alembic* /usr/lib/python3.6/site-packages/


이제 openlp가 실행될 수 있는 환경이 됩니다. openlp는 openlp 명령으로 실행할 수 있습니다.

openlp1.png



[팁] openlp를 실행하면 이 프로그램이 실행되기 전에 환경 설정 단계가 나옵니다. 설정 과정중에서 무료 성경을 다운로드하는 부분이 있는데, 한글 성경은 지원되지 않기 때문에 다운로드할 수 없습니다.  무료 성경 다운로드 과정은 생략하고, 다음 주소에 수동으로 다운로드하여 성경이 위치하는 경로로 복사 또는 이동시켜 주면 됩니다.


https://raw.githubusercontent.com/kimsg1984/openlp_contents_korean/master/bibles/%EA%B0%9C%EC%97%AD%ED%95%9C%EA%B8%80.sqlite





  1. [FAQ84] 옥션에서 MBF-BT50BK 블루투스 동글 5.0 를 구입했는데, 장치 인식이 안돼요.

    Date2020.12.02 Category네트워크 ByNo1Linuxer Reply0 Views202 Votes0 file
    Read More
  2. [FAQ83] 커널 5.8.x대로 업그레이드한 후 버추얼박스 실행시 오류가 나옵니다.

    Date2020.10.15 Category기타 ByNo1Linuxer Reply0 Views32 Votes0 file
    Read More
  3. [FAQ82] 설치 후에 엑스 윈도우로 부팅되지 않습니다.

    Date2020.09.08 Category설치/부팅 ByNo1Linuxer Reply0 Views32 Votes0
    Read More
  4. [FAQ81] 커널을 업데이트한후 시스템이 부팅되지 않습니다.

    Date2020.09.01 Category설치/부팅 ByNo1Linuxer Reply0 Views38 Votes0
    Read More
  5. [FAQ80] 커널을 업데이트한 후 시스템을 재부팅하면 콘솔로 부팅이 됩니다.

    Date2020.08.28 Category ByNo1Linuxer Reply0 Views33 Votes0
    Read More
  6. [FAQ79] 하모니카에서 설치되는 카카오톡과 넘버원 리눅스에서 설치되는 카카오톡과는 다른가요?

    Date2020.08.26 CategoryWINE ByNo1Linuxer Reply1 Views165 Votes0
    Read More
  7. [FAQ78] Lenovo Ideapad 14ARE05 4500U 노트북을 구입하였는데, 넘버원 리눅스 2019 버전으로 부팅하면 멈춥니다.

    Date2020.07.24 Category설치/부팅 ByNo1Linuxer Reply0 Views92 Votes0
    Read More
  8. [FAQ77] 카카오톡이 정상적으로 실행된 상태에서 채팅창을 클릭하면 프리징돼요.

    Date2020.06.09 CategoryWINE ByNo1Linuxer Reply0 Views123 Votes0
    Read More
  9. [FAQ76] 갑자기 사운드가 안되요.

    Date2020.05.05 Category오디오 ByNo1Linuxer Reply1 Views51 Votes0 file
    Read More
  10. [FAQ75] KDE 플라즈마에서 단축키에 대한 정의를 어떻게 확인할 수 있나요?

    Date2020.03.20 Category플라즈마 ByNo1Linuxer Reply0 Views55 Votes0 file
    Read More
  11. [FAQ74] 와이파이 네트워크를 사용하고 있는데, 콘키 화면에 와이파이 주소가 나타나질 않습니다.

    Date2020.03.16 Category네트워크 ByNo1Linuxer Reply0 Views41 Votes0 file
    Read More
  12. [FAQ73] NVidia 그래픽 카드로 넘버원 리눅스를 부팅하면 부트 과정에서 멈춥니다.

    Date2020.03.16 Category설치/부팅 ByNo1Linuxer Reply0 Views46 Votes0 file
    Read More
  13. [FAQ72] 윈도에서 토렌트로 넘버원리눅스를 다운로드하고자 하는데, 다운로드가 안됩니다.

    Date2019.12.03 Category설치/부팅 Byzharyong Reply0 Views261 Votes0 file
    Read More
  14. [FAQ71] KDE 플라즈마가 시작될 때 아무런 오류 메시지 없이 멈춥니다. 다시 시작해도 똑같습니다.

    Date2019.11.18 Category플라즈마 Byzharyong Reply0 Views69 Votes0
    Read More
  15. [FAQ70] 인터넷뱅킹을 위해 PC보안및 바이러스 차단 패키지인 astx_f64.rpm 패키지를 설치하고자 하였는데, nss-tools 의존성 문제가 있습니다.

    Date2019.11.05 Category설치/부팅 Byzharyong Reply0 Views90 Votes0
    Read More
  16. [FAQ69] 인터넷뱅킹을 위해서 공인인증서 RPM 패키지들을 강제적 설치후 시스템 이상 발생

    Date2019.10.23 Category네트워크 Byzharyong Reply0 Views86 Votes0
    Read More
  17. [FAQ68] No1.Linux 2019 버전을 저장소로부터 모든 패키지를 업데이트하였습니다. 그런데 업데이트한 후에 넘버원 리눅스 제어센터인 drakconf를 실행하면 오류가 발생됩니다.

    Date2019.09.15 Category플라즈마 Byzharyong Reply0 Views126 Votes0
    Read More
  18. [FAQ67] 교회에서 프리젠테이션을 위해 OpenLP를 사용하고자 합니다. 넘버원 리눅스 저장소로부터 이 패키지를 설치한 후 openlp를 실행하면 오류가 발생합니다. 어떻게 하면 Openlp를 실행할 수 있을까요?

    Date2019.09.10 Category오피스 Byzharyong Reply0 Views362 Votes0 file
    Read More
  19. [FAQ66] No1.Linux 2019에서 최신 버전으로 kdenlive를 19.04.1에서 19.08.1 버전으로 업데이트하였습니다. 이전 버전에서는 문제없이 실행되던 kdenlive이 최신 버전에서는 실행되지 않습니다. 어떤 문제인가요?

    Date2019.09.09 Category비디오 Byzharyong Reply0 Views655 Votes0 file
    Read More
  20. [FAQ65] 신한은행 인터넷 뱅킹은 브라우저 인증만 가능하다고 들었습니다. 브라우저 인증하는 방법에 대해서 알려 주세요.

    Date2019.09.05 Category플라즈마 Byzharyong Reply0 Views1485 Votes0 file
    Read More
목록
Board Pagination Prev 1 2 3 4 5 6 Next
/ 6